วิธีเปลี่ยน PHP7 เป็นค่า default ใน OSX

June 26, 2017

พอดีว่าได้โหลด Visual studio Code มาใช้

ทีนี้โหลดพวก Extenstion ของ PHP มา VS Code มันก็แจ้งเตือนว่าต้องการ PHP7 นะ

แต่ตอนนี้เป็น PHP 5.6 (เนื่องจากว่าลง MAMP ไว้ก่อนแล้ว)

ลองไปเปลี่ยน PHP version ใน MAMP ก็ยังไม่หาย เพราะว่า มันเปลี่ยนเฉพาะใน MAMP มันไม่ได้เปลี่ยนค่า default ของ OS

ซึ่งต้องพิมพ์คำสั่งตรวจสอบ version ใน Termimal

หมายเลข version ที่ได้จากคำสั่งนี้จะเป็น PHP ที่เป็น default ของ OS

การแก้ไข

เข้าไปที่ Terminal พิมพ์คำสั่ง

กรอกรหัสผ่านเสร็จ จะเป็นไฟล์เปล่าๆ ให้ใส่โค้ด

กด ctrl + o แล้วกด enter เพื่อทำการบันทึก เสร็จแล้วอย่าลืมพิมพ์คำสั่ง

ที่นี้ลองพิมพ์

ใน Terminal ดู จะได้หน้าตาประมาณนี้

ถ้า VS Code ยังแจ้งเตือนอยู่ ให้ Logout แล้ว Login ใหม่อีกครั้ง

 

ปล. ของผม MAMP Version 4.1.1 (492)

Mai

ชื่อใหม่ครับ ชอบการพัฒนาเว็บไซต์ ศึกษาหาข้อมูลอยู่เรื่อย มีความรู้หรือเทคนิคอะไรใหม่ๆ ก็จะมาแบ่งปันกันครับ